Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 11, 2024 - 22:00 UTC
Scheduled
EU - Germany - datacenter DE-H network will be undergoing maintenance, there could be brief spikes of suboptimal routing within the maintenance window while traffic will be shifted across carriers and peers.
Posted Oct 28, 2024 - 10:44 UTC
This scheduled maintenance affected: Gameservers EU (Germany).